Results 1 to 7 of 7

Thread: debugmode firebird langzaam

  1. #1
    Senior Member EricLang's Avatar
    Join Date
    May 2002
    Location
    Holland
    Posts
    3,040

    debugmode firebird langzaam

    Ik heb een zeer vreemd verschijnsel.
    Win applicatie met embedded firebird 3.0. (met FireDAC connection).
    In debugmode laden wat grotere datasets VEEL langzamer dan in releasemode.
    Zoiets heb ik nog nooit meegemaakt. Wat zou hiervan de oorzaak kunnen zijn?
    Groet!

  2. #2
    Debughooks. Het ligt aan hoe je je project ingesteld hebt, maar er zijn genoeg opties waardoor je programma veel trager kan draaien met debug info.

  3. #3
    Senior Member EricLang's Avatar
    Join Date
    May 2002
    Location
    Holland
    Posts
    3,040
    Debughooks? Explain please.
    Er worden diverse firebird (embedded) dll's geladen. Misschien dat daar ergens iets gruwelijks gebeurt als de IDE in debugmode is?

  4. #4
    Zou goed kunnen. Ik weet wel dat praten met DLL's veel trager gaat met bepaalde debug opties aan. Het makkelijkste is denk ik om je project options door te lopen en opties aan/uit te vinken, kijken wat effect heeft of wat niet.
    Tijdens het debuggen worden er allerlei extra dingen in de code gezet, zodat er breaks gezet kunnen worden, variabelen aangepast kunnen etc. Kan me voorstellen dat met het embedden van FB er veel checks bij komen, en veel checks maakt het uiteindelijk langzamer.

    Heb zelf ook mee gemaakt dat bepaalde dingen met bepaalde opties erg traag worden, maar nooit echt over wakker gelegen als ik eerlijk ben.

  5. #5
    Kan het zijn dat er in debug mode (meer) logs weggeschreven worden?

  6. #6
    Senior Member EricLang's Avatar
    Join Date
    May 2002
    Location
    Holland
    Posts
    3,040
    Ik zal eens kijken naar de project en debugger opties.
    Als er gelogd wordt in debugmode zou dat door FireDAC moeten gebeuren maar met andere databases heb ik daar nooit last van gehad.
    Firebird weet van niet lijkt me...

  7. #7
    Senior Member EricLang's Avatar
    Join Date
    May 2002
    Location
    Holland
    Posts
    3,040
    Ik zie inderdaad de Delphi RAD Studio enorm veel CPU nemen tijdens het openen van de dataset tijdens debugsessie.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •