Results 1 to 13 of 13

Thread: Indy versie die TLS 1.2 ondersteund

  1. #1

    Indy versie die TLS 1.2 ondersteund

    Wie weet waar ik Indy kan downloaden die TLS 1.2 ondersteund voor Delphi 2010. Want voor Delphi 5 zal die er waarschijnlijk niet meer zijn ;-)

    Ik kan eigenlijk alleen https://www.indyproject.org/download/v10/ vinden. Maar daar staat bij “This is however a rather old version and is no longer recommended.”
    Niets is zo gemakkelijk als het lijkt.

  2. #2
    indy 10 zou dat moeten kunnen, maar je moet dan ook wel de juiste openssl dll's meeleveren.

  3. #3
    Ik heb nu Indy 10.5.5 geïnstalleerd. Maar heb nog steeds sslvTLSv1. Ik heb de laatste dll's van https://indy.fulgan.com/SSL/ toegevoegd.

    [edit]
    Denk dat ik nog een nieuwere versie van Indy moet hebben. Iemand enig idee waar ik die kan vinden? Op http://indy.fulgan.com/ZIP/ staan ze niet meer.
    Last edited by Greta; 18-Jan-20 at 11:15.
    Niets is zo gemakkelijk als het lijkt.

  4. #4
    https://indy.fulgan.com/SSL/

    Je moet wel de juiste downloaden, vermoedelijk in jouw geval de 32 bits.

    Wij gebruiken TLS v1.2 in een applicatie bij een klant, die nog draait op delphi 2007. We hebben wel de standaard indy die daarbij zat moeten upgraden naar een 10 versie (weet zo even niet exact welke). Maar het zou in jouw D2010 dus zeker moeten gaan werken.

  5. #5
    Ja, die dll’s heb ik al wel. Maar de Indy 10.5.5 die ik heb gaat niet verder dan sslvTLSv1. Ik heb al wel op internet gevonden dat TLS 1.2 wel in Indy versie 10.5.8.0 zou moeten zitten. Maar ik kan nergens een Indy installeerbaar package vinden. Staan namelijk niet meer op http://indy.fulgan.com/ZIP/. Er staat daar vermeld: “All source code can be accessed from https://github.com/IndySockets” Alleen heb ik geen idee hoe ik wat daar staat zou moeten installeren.

    Dus ben nu opzoek of nog ergens een zip met een nieuwere Indy versie op internet te vinden is voor Delphi 5, 7 of 10.
    Niets is zo gemakkelijk als het lijkt.

  6. #6
    Fornicatorus Formicidae VideoRipper's Avatar
    Join Date
    Mar 2005
    Location
    Vicus Saltus Orientalem
    Posts
    5,469
    Ik heb hier Indy 10.6.2.5517 (klik op de groene "Clone or download" knop rechtsboven in het scherm en dan "Download ZIP") op mijn D2007 installatie met de OpenSSL-libraries van mei 2019 (openssl-1.0.2s-i386-win32) en die kunnen prima overweg met TLS1.2. De instructies voor hoe je Indy 10 moet installeren staan hier.
    Last edited by VideoRipper; 21-Jan-20 at 10:07.
    TMemoryLeak.Create(Nil);

  7. #7
    Bedankt, ik had deze ook al eerder gezien maar krijg het niet geïnstalleerd. Zal ongetwijfeld iets niet goed doen :-)

    Daarom was ik opzoek naar een gecompileerde versie

    Als ik Fulld_5.bat start krijg ik de volgende meldingen:
    \indy\Lib\Protocols\IdIMAP4Server.pas(730) Error: For loop control variable must have ordinal type
    \indy\Lib\Protocols\IdIMAP4Server.pas(2707)
    \indy\Lib\Protocols\IndyProtocols50.dpk(267) Fatal: Could not compile used unit 'IdIMAP4Server.pas'
    'clean' is not recognized as an internal or external command,
    operable program or batch file.
    Error!

    Bij Fulld_5.bat
    \indy\Lib\Protocols\IdIMAP4Server.pas(730) Error: For loop control variable must have ordinal type
    \indy\Lib\Protocols\IdIMAP4Server.pas(2707)
    \indy\Lib\Protocols\IndyProtocols70.dpk(268) Fatal: Could not compile used unit 'IdIMAP4Server.pas'
    'clean' is not recognized as an internal or external command,
    operable program or batch file.
    Error!

    Als ik de Fullc_XE.bat probeer krijg ik:
    Resetting registry rootkey to HKCU, and retrying
    Compiler not installed!
    Error!
    Niets is zo gemakkelijk als het lijkt.

  8. #8
    Fornicatorus Formicidae VideoRipper's Avatar
    Join Date
    Mar 2005
    Location
    Vicus Saltus Orientalem
    Posts
    5,469
    Dat was ik vergeten erbij te vermelden: je moet niet de batchbestanden gebruiken, het is mij althans nog nooit gelukt om op die manier Indy te installeren.

    Wat je moet doen is eerst zorgen dat een eventuele oude versie van Indy 10 verwijderd is en voeg je de paden (Lib\System, Lib\Core en Lib\Protocols) naar de code van de nieuwe Indy versies toe aan je search path.
    Daarna moet je alle DPK's handmatig builden (en de laatste twee installeren) in deze volgorde:
    1. IndySystemX0.dpk (in Lib\System)
    2. IndyCoreX0.dpk (in Lib\Core)
    3. IndyProtocolsX0.dpk (in Lib\Protocols)
    4. dclIndyCoreX0.dpk (in Lib\Core)
    5. dclIndyProtocolsX0.dpk (in Lib\Protocols)
    TMemoryLeak.Create(Nil);

  9. #9
    John Kuiper
    Join Date
    Apr 2007
    Location
    Almere
    Posts
    8,643
    Misschien toch een optie om over te gaan op Lazarus
    Delphi is great. Lazarus is more powerfull

  10. #10
    Bedankt voor de tip. Ga een nieuwe poging doen.

    Ja ik ben al een beetje aan het kijken naar Lazarus. Maar heb de grote stap nog niet gezet. :-)
    Niets is zo gemakkelijk als het lijkt.

  11. #11
    Ik krijg een Fatal Error bij de build van IndyProtocols140.dpk
    Ik heb de 140 omdat die volgens mij delphi 2010 is. En een IndySystemX0.dpk is er niet.

    Checking project dependencies...
    Compiling IndyProtocols140.dproj (Debug configuration)
    [DCC Hint] IdSSLOpenSSL.pas(1268): H2077 Value assigned to 'Lin' never used
    [DCC Hint] IdSSLOpenSSL.pas(1355): H2077 Value assigned to 'Lin' never used
    [DCC Hint] IdSSLOpenSSL.pas(2580): H2077 Value assigned to 'TIdServerIOHandlerSSLOpenSSL.Accept' never used
    [DCC Warning] IdDNSServer.pas(1939): W1000 Symbol 'FillResultWithOutCheckId' is deprecated: 'Use FillResult() with checkID=False'
    [DCC Warning] IdDNSServer.pas(3891): W1000 Symbol 'FillResultWithOutCheckId' is deprecated: 'Use FillResult() with checkID=False'
    [DCC Warning] IdIMAP4.pas(2910): W1036 Variable 'LNonSyncLiteralIsLimited' might not have been initialized
    [DCC Error] IdIMAP4Server.pas(730): E2032 For loop control variable must have ordinal type
    [DCC Fatal Error] IndyProtocols140.dpk(269): F2063 Could not compile used unit 'IdIMAP4Server.pas'
    Failed
    Elapsed time: 00:00:02.0

    Deze error krijg ik bij: “for LN := LStart to LEnd do begin”
    De variabele LN is een integer
    Niets is zo gemakkelijk als het lijkt.

  12. #12
    Fornicatorus Formicidae VideoRipper's Avatar
    Join Date
    Mar 2005
    Location
    Vicus Saltus Orientalem
    Posts
    5,469
    Hints en warnings in ingecheckte code kan ik mij altijd danig aan ergeren, maar die kun je nu even negeren. De error is wel opmerkelijk: zowel LN als LStart en LEnd waren oorspronkelijk gewone Integers (ik werk met die versies), maar zijn op 25 november 2019 door Remy aangepast naar Int64's (en nu werkt het daar niet meer).
    Click image for larger version. 

Name:	TIdIMAP4Server.png 
Views:	45 
Size:	54.0 KB 
ID:	8057
    Wellicht is het handig om zijn wijzigingen in die unit terug te draaien om zaken werkend te krijgen.

    Als dat niet lukt kun je ook de versie nemen die ik gebruik, die werkt in ieder geval.
    Last edited by VideoRipper; 24-Jan-20 at 14:02.
    TMemoryLeak.Create(Nil);

  13. #13
    Bedankt!!!. Ik heb die van jou gebruikt. En die werkt
    Niets is zo gemakkelijk als het lijkt.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •