Results 1 to 2 of 2

Thread: [Beta1] Entities bug...

  1. #1
    Senior Member PsychoMark's Avatar
    Join Date
    Nov 2001
    Location
    Raamsdonksveer
    Posts
    10,269

    [Beta1] Entities bug...

    Op dit moment wordt een '©' in de XML file waarschijnlijk vertaald naar '©', waardoor je dus 'copy;' in je applicatie krijgt. Niet goed. Naar de oorzaak zal ik vanavond eens gaan zoeken...
    Qui custodiet ipsos custodes

  2. #2
    Senior Member PsychoMark's Avatar
    Join Date
    Nov 2001
    Location
    Raamsdonksveer
    Posts
    10,269
    De fout is gevonden. Het gebeurt alleen als je in NLDTDefines.inc NLDT_FASTSTRINGS aan hebt staan, de oplossing:


    In NLDTXDOMUtils.pas, de functie XDOMEntityToChar, de regel "Result := ASource;" verplaatsen naar direct na de eerste 'begin', als allereerste regel van de functie dus.



    Voor degenen die FastStrings niet hebben, in NLDTDefines.inc zet een punt voor $DEFINE bij {$DEFINE NLDT_FASTSTRINGS}, NLDTranslate zal nu native Delphi functies gebruiken...



    Ik zal de download ook even aanpassen, maar daarvoor moet ik even wachten tot Marcel het bestand weer kan uploaden. Tot die tijd is dit de enige fix die nodig is
    Qui custodiet ipsos custodes

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. MessageBox bug?
    By Marcel0000 in forum Koffiehoek
    Replies: 4
    Last Post: 25-Apr-04, 05:45
  2. Vreemde bug met WideStrings
    By Dunebuggy in forum Algemeen
    Replies: 6
    Last Post: 24-May-03, 12:04
  3. Bug in d5????
    By JEROENH in forum Algemeen
    Replies: 7
    Last Post: 28-Apr-03, 14:28
  4. bug hoort in andere draadje sorry
    By zkinny in forum Databases
    Replies: 1
    Last Post: 16-Sep-02, 20:14

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •